Cross-site scripting in Crafter CMS Crafter StudioGHSA-ph76-rhqq-xj7j
MEDIUMGHSA-ph76-rhqq-xj7j is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in org.craftercms:crafter-studio. A fix is available for org.craftercms:crafter-studio — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.craftercms:crafter-studioReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Crafter CMS Crafter Studio 3.0.1 is affected by: Cross Site Scripting (XSS), which allows remote attackers to steal users’ cookies.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.craftercms:crafter-studio | all versions | 3.0.2org.craftercms:crafter-studio:3.0.2 |
Affected Products
crafter cmscraftercmsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.craftercms:crafter-studio, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.craftercms:crafter-studio to 3.0.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-ph76-rhqq-xj7j is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-ph76-rhqq-xj7j in your dependencies?
Find it across Maven, including transitive dependencies.