NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
CRITICAL severity

CVE-2017-15681 — crafter-studio

CRITICAL

CVE-2017-15681 is a critical-severity (CVSS 9.8) Path Traversal vulnerability in org.craftercms:crafter-studio. A fix is available for org.craftercms:crafter-studio — see the affected versions and patch details below.

Path Traversal in Crafter CMS Crafter Studio

Also known asGHSA-7c6q-jqwc-4423
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs81th percentile — riskier than 81% of all scored CVEsHighest risk
1.48%1.84%2.20%2.57%2.0%2.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.craftercms:crafter-studio

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

In Crafter CMS Crafter Studio 3.0.1 a directory traversal vulnerability exists which allows unauthenticated attackers to overwrite files from the operating system which can lead to RCE.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.craftercms:crafter-studioall versions3.0.2org.craftercms:crafter-studio:3.0.2

Affected Products

1 product · 1 configurations
Application
crafter cmscraftercms
≥ 3.0.0 && < 3.0.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.craftercms:crafter-studio, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.craftercms:crafter-studio to 3.0.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2017-15681 is resolved across your whole dependency graph.

  3. Workarounds

    Resolve every user-supplied path to its canonical form and reject anything that escapes the intended directory, and run the component under an account that has no read or write access outside the directory it legitimately serves.

Frequently Asked Questions

In Crafter CMS Crafter Studio 3.0.1 a directory traversal vulnerability exists which allows unauthenticated attackers to overwrite files from the operating system which can lead to RCE.
O3 Security · Impact-Aware SCA

Is CVE-2017-15681 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2017-15681: crafter-studio RCE — Fixed in 3.0.2