Orchid Deserialization of Untrusted Data vulnerability leads to Remote Code ExecutionGHSA-ph6g-p72v-pc3p
CRITICALGHSA-ph6g-p72v-pc3p is a critical-severity (CVSS 9.8) Deserialization of Untrusted Data vulnerability in orchid/platform. A fix is available for orchid/platform — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-ph6g-p72v-pc3p.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
orchid/platformReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Orchid is a Laravel package that allows application development of back-office applications, admin/user panels, and dashboards.
Impact
A vulnerability present starting in version 14.0.0-alpha4 and prior to version 14.5.0 is related to the deserialization of untrusted data from the _state query parameter, which can result in remote code execution. This vulnerability is related to the deserialization of untrusted data from the _state query parameter, which can result in remote code execution.
Patches
The issue has been addressed in version 14.5.0. Users are advised to upgrade their software to this version or any subsequent versions that include the patch. There are no known workarounds.
Workarounds
In this case, it is recommended for users to upgrade to the patched version rather than relying on workarounds. Upgrading to the fixed version ensures that the vulnerability is no longer present and provides the best protection against remote code execution
References
For more detailed information about this workaround and its effectiveness, users should consult the support channels provided by the software or system developer. They can provide specific guidance on implementing this workaround and any potential limitations or caveats associated with it.
This vulnerability was discovered by Vladislav Gladkiy (Positive Technologies)
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | orchid/platform | ≥ 14.0.0-alpha4&&< 14.5.0 | 14.5.0composer require orchid/platform:^14.5.0 |
Affected Products
platformorchidDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for orchid/platform, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update orchid/platform to 14.5.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-ph6g-p72v-pc3p is resolved across your whole dependency graph.
Workarounds
Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.
Frequently Asked Questions
Is GHSA-ph6g-p72v-pc3p in your dependencies?
Find it across Packagist, including transitive dependencies.