NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
CRITICAL severity

CVE-2023-36825 — platform

CRITICAL

CVE-2023-36825 is a critical-severity (CVSS 9.6) Deserialization of Untrusted Data vulnerability in orchid/platform. A fix is available for orchid/platform — see the affected versions and patch details below.

Orchid Deserialization of Untrusted Data vulnerability leads to Remote Code Execution

Also known asGHSA-ph6g-p72v-pc3p
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2023-36825.

EPSS Exploitation Probability

via FIRST.org ↗
1.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs66th percentile — riskier than 66% of all scored CVEsHighest risk
0.00%2.99%5.97%8.96%7.1%1.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘orchid/platform

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Orchid is a Laravel package that allows application development of back-office applications, admin/user panels, and dashboards.

Impact

A vulnerability present starting in version 14.0.0-alpha4 and prior to version 14.5.0 is related to the deserialization of untrusted data from the _state query parameter, which can result in remote code execution. This vulnerability is related to the deserialization of untrusted data from the _state query parameter, which can result in remote code execution.

Patches

The issue has been addressed in version 14.5.0. Users are advised to upgrade their software to this version or any subsequent versions that include the patch. There are no known workarounds.

Workarounds

In this case, it is recommended for users to upgrade to the patched version rather than relying on workarounds. Upgrading to the fixed version ensures that the vulnerability is no longer present and provides the best protection against remote code execution

References

For more detailed information about this workaround and its effectiveness, users should consult the support channels provided by the software or system developer. They can provide specific guidance on implementing this workaround and any potential limitations or caveats associated with it.


This vulnerability was discovered by Vladislav Gladkiy (Positive Technologies)

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistorchid/platform≥ 14.0.0-alpha4&&< 14.5.014.5.0composer require orchid/platform:^14.5.0

Affected Products

1 product · 6 configurations
Application
platformorchid
≥ 14.0.1 && < 14.5.0
1 version
14.0.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for orchid/platform, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update orchid/platform to 14.5.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2023-36825 is resolved across your whole dependency graph.

  3. Workarounds

    Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.

Frequently Asked Questions

Orchid is a Laravel package that allows application development of back-office applications, admin/user panels, and dashboards. ### Impact A vulnerability present starting in version 14.0.0-alpha4 and prior to version 14.5.0 is related to the deserialization of untrusted data from the `_state` query parameter, which can result in remote code execution. This vulnerability is related to the deserialization of untrusted data from the `_state` query parameter, which can result in remote code execution. ### Patches The issue has been addressed in version 14.5.0. Users are advised to upgrade the
O3 Security · Impact-Aware SCA

Is CVE-2023-36825 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2023-36825: platform RCE — Fixed in 14.5.0