GHSA-pgwj-prpq-jpc2 is a critical-severity (CVSS 9.8) SQL Injection vulnerability in symfony/dependency-injection. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for symfony/dependency-injection — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
symfony/dependency-injection🐘symfony/dependency-injection🐘symfony/dependency-injection🐘symfony/dependency-injection🐘symfony/dependency-injection🐘symfony/proxy-manager-bridge🐘symfony/proxy-manager-bridge🐘symfony/proxy-manager-bridge+7 moreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
In Symfony before 2.7.51, 2.8.x before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and 4.2.x before 4.2.7, when service ids allow user input, this could allow for SQL Injection and remote code execution. This is related to symfony/dependency-injection.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | symfony/dependency-injection | ≥ 2.7.0&&< 2.7.51 | 2.7.51composer require symfony/dependency-injection:^2.7.51 |
| 🐘Packagist | symfony/dependency-injection | ≥ 2.8.0&&< 2.8.50 | 2.8.50composer require symfony/dependency-injection:^2.8.50 |
| 🐘Packagist | symfony/dependency-injection | ≥ 3.0.0&&< 3.4.26 | 3.4.26composer require symfony/dependency-injection:^3.4.26 |
| 🐘Packagist | symfony/dependency-injection | ≥ 4.0.0&&< 4.1.12 | 4.1.12composer require symfony/dependency-injection:^4.1.12 |
| 🐘Packagist | symfony/dependency-injection | ≥ 4.2.0&&< 4.2.7 | 4.2.7composer require symfony/dependency-injection:^4.2.7 |
| 🐘Packagist | symfony/proxy-manager-bridge | ≥ 2.7.0&&< 2.7.51 | 2.7.51composer require symfony/proxy-manager-bridge:^2.7.51 |
Affected Products
drupaldrupalsymfonysensiolabsResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for symfony/dependency-injection, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update symfony/dependency-injection to 2.7.51 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-pgwj-prpq-jpc2 is resolved across your whole dependency graph.
Workarounds
Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.
Frequently Asked Questions
Is GHSA-pgwj-prpq-jpc2 in your dependencies?
Find it across Packagist, including transitive dependencies.