Rails has a possible XSS vulnerability in its Action Pack debug exceptionsGHSA-pgm4-439c-5jp6
Fix: rails/rails@6752711GHSA-pgm4-439c-5jp6 is a Cross-site Scripting (XSS) vulnerability in actionpack. A fix is available for actionpack — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-pgm4-439c-5jp6.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
actionpackReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.
Description
Impact
The debug exceptions page does not properly escape exception messages. A carefully crafted exception message could inject arbitrary HTML and JavaScript into the page, leading to XSS. This affects applications with detailed exception pages enabled (config.consider_all_requests_local = true), which is the default in development.
Releases
The fixed releases are available at the normal locations.
Credit
This issue was responsibly reported by Hackerone researcher fbettag.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 💎RubyGems | actionpack | ≥ 8.1.0&&< 8.1.2.1 | 8.1.2.1bundle update actionpack --conservative |
Affected Products
railsrubyonrailsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for actionpack, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update actionpack to 8.1.2.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-pgm4-439c-5jp6 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
To mitigate this issue, ensure that `config.consider_all_requests_local` is set to `false` in production environments for Rails applications. This configuration prevents the display of detailed exception pages, thereby eliminating the vector for this XSS vulnerability. This change may require a restart of the Rails application to take effect.Source: Red Hat security advisory for GHSA-pgm4-439c-5jp6 (CC BY 4.0)
Frequently Asked Questions
Is GHSA-pgm4-439c-5jp6 in your dependencies?
Find it across RubyGems, including transitive dependencies.