Cross-Site Scripting (XSS) vulnerability in typolinksGHSA-p5c5-gmj4-g48f
GHSA-p5c5-gmj4-g48f is a security vulnerability in typo3/cms. A fix is available for typo3/cms — see the affected versions and patch details below.
Real-World Exposure
typo3/cms🐘typo3/cms🐘typo3/cmsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
All link fields within the TYPO3 installation are vulnerable to Cross-Site Scripting as authorized editors can insert data commands by using the url scheme "data:".
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | typo3/cms | ≥ 6.2.0&&< 6.2.26 | 6.2.26composer require typo3/cms:^6.2.26 |
| 🐘Packagist | typo3/cms | ≥ 7.6.0&&< 7.6.10 | 7.6.10composer require typo3/cms:^7.6.10 |
| 🐘Packagist | typo3/cms | ≥ 8.0.0&&< 8.2.1 | 8.2.1composer require typo3/cms:^8.2.1 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update typo3/cms to 6.2.26 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-p5c5-gmj4-g48f is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-p5c5-gmj4-g48f in your dependencies?
Find it across Packagist, including transitive dependencies.