NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

Invalid push request payload crashes Parse ServerGHSA-mxhg-rvwx-x993

MEDIUMFix: parse-community/parse-server-push-adapter#217

GHSA-mxhg-rvwx-x993 is a medium-severity (CVSS 4.9) Improper Input Validation vulnerability in parse-server-push-adapter. A fix is available for parse-server-push-adapter — see the affected versions and patch details below.

Also known asCVE-2023-32688
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-mxhg-rvwx-x993.

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs60th percentile — riskier than 60% of all scored CVEsHighest risk
0.00%0.47%0.93%1.40%0.2%0.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, a proxy for how much of the ecosystem is exposed.

parse-server-push-adapternpm
1Kdownloads / week

Description

Impact

The Parse Server Push Adapter can crash Parse Server due to an invalid push notification payload.

Patches

Invalid push notification payload is caught and an logged.

Workarounds

n/a

References

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmparse-server-push-adapterall versions4.1.3npm install parse-server-push-adapter@4.1.3

Affected Products

1 product · 1 configurations
Application
parse server push adapterparseplatform
< 4.1.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for parse-server-push-adapter, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update parse-server-push-adapter to 4.1.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-mxhg-rvwx-x993 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Impact The Parse Server Push Adapter can crash Parse Server due to an invalid push notification payload. ### Patches Invalid push notification payload is caught and an logged. ### Workarounds n/a ### References - https://github.com/parse-community/parse-server-push-adapter/security/advisories/GHSA-mxhg-rvwx-x993 - https://github.com/parse-community/parse-server-push-adapter/pull/217
O3 Security · Impact-Aware SCA

Is GHSA-mxhg-rvwx-x993 in your dependencies?

Find it across npm, including transitive dependencies.

Invalid push request payload crashes Parse Server