NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

Next Vulnerable to Denial of Service with Server ComponentsGHSA-mwv6-3258-q52c

HIGH

GHSA-mwv6-3258-q52c is a high-severity (CVSS 7.5) remote code execution vulnerability in next. A fix is available for next — see the affected versions and patch details below.

Published
Updated
Affected
10 pkgs
Patched
10 / 10
Exploits
None indexed
Exploitation data as of Sep 10, 2026 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

10 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

61Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
nextnpm
91.0Mdownloads / week

Description

A vulnerability affects certain React packages for versions 19.0.0, 19.0.1, 19.1.0, 19.1.1, 19.1.2, 19.2.0, and 19.2.1 and frameworks that use the affected packages, including Next.js 15.x and 16.x using the App Router. The issue is tracked upstream as CVE-2025-55184.

A malicious HTTP request can be crafted and sent to any App Router endpoint that, when deserialized, can cause the server process to hang and consume CPU. This can result in denial of service in unpatched environments.

Affected Packages

10 total 10 fixed
EcosystemPackageVulnerable rangeFix
📦npmnext≥ 13.3.0&&< 14.2.3414.2.34npm install next@14.2.34
📦npmnext≥ 15.0.0-canary.0&&< 15.0.615.0.6npm install next@15.0.6
📦npmnext≥ 15.1.1-canary.0&&< 15.1.1015.1.10npm install next@15.1.10
📦npmnext≥ 15.2.0-canary.0&&< 15.2.715.2.7npm install next@15.2.7
📦npmnext≥ 15.3.0-canary.0&&< 15.3.715.3.7npm install next@15.3.7
📦npmnext≥ 15.4.0-canary.0&&< 15.4.915.4.9npm install next@15.4.9

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for next, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update next to 14.2.34 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-mwv6-3258-q52c is resolved across your whole dependency graph.

  3. Workarounds

    Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.

Frequently Asked Questions

A vulnerability affects certain React packages for versions 19.0.0, 19.0.1, 19.1.0, 19.1.1, 19.1.2, 19.2.0, and 19.2.1 and frameworks that use the affected packages, including Next.js 15.x and 16.x using the App Router. The issue is tracked upstream as [CVE-2025-55184](https://www.cve.org/CVERecord?id=CVE-2025-55184). A malicious HTTP request can be crafted and sent to any App Router endpoint that, when deserialized, can cause the server process to hang and consume CPU. This can result in denial of service in unpatched environments.
O3 Security · Impact-Aware SCA

Is GHSA-mwv6-3258-q52c in your dependencies?

Find it across npm, including transitive dependencies.

Next Vulnerable to Denial of Service with Server…