Your RSA-2048 keys break in 2030. Find every one of them before attackers do.
📦 npm
Not in CISA KEV

CVE-2026-64646 — next

Fix: vercel/next.js@57c31f7

CVE-2026-64646 is a CWE-770 vulnerability in next. A fix is available for next — see the affected versions and patch details below.

Next.js: Unbounded Server Action payload in Edge runtime

Also known asGHSA-4c39-4ccg-62r3
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Oct 24, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2026-64646.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk-0.01%
Lower risk than most CVEs44th percentile — riskier than 44% of all scored CVEsHighest risk
0.02%0.36%0.70%1.03%0.5%0.5%Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

2 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

61Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
nextnpm
44.6Mdownloads / week

Description

Next.js is a React framework for building full-stack web applications. In versions 13.0.0 through 15.5.20 and 16.0.0 through 16.2.10, requests targeting Next.js applications using App Router with at least one Server Action can lead to excessive memory consumption if that Server Actions uses the Edge runtime. This issue has been fixed in versions 15.5.21 and 16.2.11.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
📦npmnext≥ 13.0.0&&< 15.5.2115.5.21npm install next@15.5.21
📦npmnext≥ 16.0.0&&< 16.2.1116.2.11npm install next@16.2.11

Affected Products

1 product · 2 configurations
Application
next.jsvercel
≥ 16.0.0 && < 16.2.11
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for next, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update next to 15.5.21 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2026-64646 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant

An Important denial of service flaw exists in Next.js applications utilizing the App Router with Server Actions configured to use the Edge runtime. This vulnerability can lead to excessive memory consumption, potentially causing service unavailability. Red Hat products that embed or deploy Next.js applications with…

ProductFixed inAdvisory
Streams for Apache Kafka 3.2.1nextRHSA-2026:54435

Frequently Asked Questions

Next.js is a React framework for building full-stack web applications. In versions 13.0.0 through 15.5.20 and 16.0.0 through 16.2.10, requests targeting Next.js applications using App Router with at least one Server Action can lead to excessive memory consumption if that Server Actions uses the Edge runtime. This issue has been fixed in versions 15.5.21 and 16.2.11.
O3 Security · Impact-Aware SCA

Is CVE-2026-64646 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2026-64646: next — Fixed in 15.5.21