NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕ Maven
Not in CISA KEV

OpenSearch is vulnerable to DoS via complex query_string inputsGHSA-mw3v-mmfw-3x2g

Fix: opensearch-project/OpenSearch#19491

GHSA-mw3v-mmfw-3x2g is a CWE-674 vulnerability in org.opensearch:opensearch-common. A fix is available for org.opensearch:opensearch-common — see the affected versions and patch details below.

Also known asCVE-2025-9624
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for GHSA-mw3v-mmfw-3x2g.

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs54th percentile — riskier than 54% of all scored CVEsHighest risk
0.00%0.41%0.82%1.23%0.0%0.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

2 pkgs affected
☕org.opensearch:opensearch-common☕org.opensearch:opensearch-common

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

A vulnerability in OpenSearch allows attackers to cause Denial of Service (DoS) by submitting complex query_string inputs.

This issue affects all OpenSearch versions between 3.0.0 and < 3.3.0 and OpenSearch < 2.19.4.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.opensearch:opensearch-common≥ 3.0.0&&< 3.3.03.3.0org.opensearch:opensearch-common:3.3.0
☕Mavenorg.opensearch:opensearch-commonall versions2.19.4org.opensearch:opensearch-common:2.19.4

Affected Products

1 product · 1 configurations
Application
opensearchamazon
< 3.3.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.opensearch:opensearch-common, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.opensearch:opensearch-common to 3.3.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-mw3v-mmfw-3x2g is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

A vulnerability in OpenSearch allows attackers to cause Denial of Service (DoS) by submitting complex query_string inputs. This issue affects all OpenSearch versions below 2.19.4 and versions 3.0.0 through 3.2.0.
O3 Security · Impact-Aware SCA

Is GHSA-mw3v-mmfw-3x2g in your dependencies?

Find it across Maven, including transitive dependencies.

OpenSearch is vulnerable to DoS via complex…