CVE-2025-9624 — opensearch-common
Fix: opensearch-project/OpenSearch#19491CVE-2025-9624 is a CWE-674 vulnerability in org.opensearch:opensearch-common. A fix is available for org.opensearch:opensearch-common — see the affected versions and patch details below.
OpenSearch 3.2.0 - Nested Boolean/Disjunction asymmetric DoS
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
Exploitation and automatability from CISA’s SSVC triage for CVE-2025-9624.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
org.opensearch:opensearch-common☕org.opensearch:opensearch-commonReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
A vulnerability in OpenSearch allows attackers to cause Denial of Service (DoS) by submitting complex query_string inputs.
This issue affects all OpenSearch versions between 3.0.0 and < 3.3.0 and OpenSearch < 2.19.4.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.opensearch:opensearch-common | ≥ 3.0.0&&< 3.3.0 | 3.3.0org.opensearch:opensearch-common:3.3.0 |
| ☕Maven | org.opensearch:opensearch-common | all versions | 2.19.4org.opensearch:opensearch-common:2.19.4 |
Affected Products
opensearchamazonDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.opensearch:opensearch-common, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.opensearch:opensearch-common to 3.3.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2025-9624 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is CVE-2025-9624 in your dependencies?
Find it across Maven, including transitive dependencies.