SVG Injection via Unsanitized Options in @dicebear/core and @dicebear/initialsGHSA-mr9r-mww3-v6gv
MEDIUMGHSA-mr9r-mww3-v6gv is a medium-severity (CVSS 4.7) Cross-site Scripting (XSS) vulnerability in @dicebear/core. A fix is available for @dicebear/core — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-mr9r-mww3-v6gv.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
@dicebear/corenpmDescription
Summary
SVG attribute values derived from user-supplied options (backgroundColor, fontFamily, textColor) were not XML-escaped before interpolation into SVG output. This could allow Cross-Site Scripting (XSS) when applications pass untrusted input to createAvatar() and serve the resulting SVG inline or with Content-Type: image/svg+xml.
Affected packages
@dicebear/core—backgroundColoroption values interpolated into SVG attributes without escaping (affectssolidandgradientLinearbackground types)@dicebear/initials—fontFamilyandtextColoroption values interpolated into SVG attributes without escaping
Fix
All affected SVG attribute values are now properly escaped using XML entity encoding. Users should upgrade to the listed patched versions.
Mitigating factors
- Applications that validate input against the library's JSON Schema before passing it to
createAvatar()are not affected - The DiceBear CLI validates input via AJV and was not vulnerable
- Exploitation requires that an application passes untrusted, unvalidated external input directly as option values
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | @dicebear/core | ≥ 5.0.0&&< 5.4.4 | 5.4.4npm install @dicebear/core@5.4.4 |
| 📦npm | @dicebear/core | ≥ 6.0.0&&< 6.1.4 | 6.1.4npm install @dicebear/core@6.1.4 |
| 📦npm | @dicebear/core | ≥ 7.0.0&&< 7.1.4 | 7.1.4npm install @dicebear/core@7.1.4 |
| 📦npm | @dicebear/core | ≥ 8.0.0&&< 8.0.3 | 8.0.3npm install @dicebear/core@8.0.3 |
| 📦npm | @dicebear/core | ≥ 9.0.0&&< 9.4.1 | 9.4.1npm install @dicebear/core@9.4.1 |
| 📦npm | @dicebear/initials | ≥ 5.0.0&&< 5.4.4 | 5.4.4npm install @dicebear/initials@5.4.4 |
Affected Products
dicebeardicebearDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @dicebear/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update @dicebear/core to 5.4.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-mr9r-mww3-v6gv is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-mr9r-mww3-v6gv in your dependencies?
Find it across npm, including transitive dependencies.