goxmldsig vulnerable to crash on nil-pointer dereference caused by sending malformed XML signaturesGHSA-mqqv-chpx-vq25
HIGHGHSA-mqqv-chpx-vq25 is a high-severity (CVSS 7.5) NULL Pointer Dereference vulnerability in github.com/russellhaering/goxmldsig. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for github.com/russellhaering/goxmldsig — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/russellhaering/goxmldsig🐹github.com/russellhaering/gosaml2Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
This affects all versions of package github.com/russellhaering/goxmldsig prior to 1.1.1. There is a crash on nil-pointer dereference caused by sending malformed XML signatures. This issue is patched in version 1.1.1.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/russellhaering/goxmldsig | all versions | 1.1.1go get github.com/russellhaering/goxmldsig@v1.1.1 |
| 🐹Go | github.com/russellhaering/gosaml2 | all versions | 0.7.0go get github.com/russellhaering/gosaml2@v0.7.0 |
Affected Products
goxmldsiggoxmldsig_projectResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/russellhaering/goxmldsig, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/russellhaering/goxmldsig to 1.1.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-mqqv-chpx-vq25 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-mqqv-chpx-vq25 in your dependencies?
Find it across Go, including transitive dependencies.