silverstripe/framework CSV Excel Macro InjectionGHSA-mqjc-x563-c9q8
HIGHFix: silverstripe/silverstripe-framework@55739faGHSA-mqjc-x563-c9q8 is a high-severity (CVSS 8) vulnerability in silverstripe/framework. A fix is available for silverstripe/framework — see the affected versions and patch details below.
Real-World Exposure
silverstripe/framework🐘silverstripe/framework🐘silverstripe/frameworkReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
In the CSV export feature of the CMS it's possible for the output to contain macros and scripts, which if imported without sanitisation into software (including Microsoft Excel) may be executed.
In order to safeguard against this threat all potentially executable cell values exported from CSV will be prepended with a literal tab character.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | silverstripe/framework | ≥ 3.5.0-rc1&&< 3.5.6 | 3.5.6composer require silverstripe/framework:^3.5.6 |
| 🐘Packagist | silverstripe/framework | ≥ 3.6.0-rc1&&< 3.6.3 | 3.6.3composer require silverstripe/framework:^3.6.3 |
| 🐘Packagist | silverstripe/framework | ≥ 4.0.0-rc1&&< 4.0.1 | 4.0.1composer require silverstripe/framework:^4.0.1 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for silverstripe/framework, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update silverstripe/framework to 3.5.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-mqjc-x563-c9q8 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-mqjc-x563-c9q8 in your dependencies?
Find it across Packagist, including transitive dependencies.