Ineffective privileges drop when requesting container networkGHSA-mmx5-32m4-wxvx
MEDIUMFix: apptainer/apptainer#1523GHSA-mmx5-32m4-wxvx is a medium-severity (CVSS 6.1) Improper Privilege Management vulnerability in github.com/apptainer/apptainer. A fix is available for github.com/apptainer/apptainer — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-mmx5-32m4-wxvx.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/apptainer/apptainerReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Impact
Fix https://github.com/apptainer/apptainer/pull/1523 included in Apptainer 1.2.0-rc.2 has introduced an ineffective privilege drop when requesting container network setup, therefore subsequent functions are called with root privileges. The attack surface is rather limited for users but an attacker could possibly craft a starter config to delete any directory on the host filesystems. Only affects setuid installations of Apptainer.
Patches
The security fix https://github.com/apptainer/apptainer/pull/1578 has been included in Apptainer 1.2.1
Workarounds
There is no known workaround outside of upgrading to Apptainer 1.2.1
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/apptainer/apptainer | ≥ 1.2.0&&< 1.2.1 | 1.2.1go get github.com/apptainer/apptainer@v1.2.1 |
Affected Products
apptainerlfprojectsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/apptainer/apptainer, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/apptainer/apptainer to 1.2.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-mmx5-32m4-wxvx is resolved across your whole dependency graph.
Workarounds
Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.
Frequently Asked Questions
Is GHSA-mmx5-32m4-wxvx in your dependencies?
Find it across Go, including transitive dependencies.