Symfony XML decoding attack vector through external entitiesGHSA-mmcv-fvq8-r9x3
CRITICALFix: symfony/symfony@3e64d36GHSA-mmcv-fvq8-r9x3 is a critical-severity (CVSS 9.8) remote code execution vulnerability in symfony/symfony. A fix is available for symfony/symfony — see the affected versions and patch details below.
Real-World Exposure
symfony/symfonyReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
The XMLEncoder component of Symfony 2.0.x fails to disable external entities when parsing XML. In the Symfony2 framework the XML class may be used to deserialize objects or as part of a client/server API. By using external entities it is possible to include arbitrary files from the file system.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | symfony/symfony | ≥ 2.0.0&&< 2.0.11 | 2.0.11composer require symfony/symfony:^2.0.11 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for symfony/symfony, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update symfony/symfony to 2.0.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-mmcv-fvq8-r9x3 is resolved across your whole dependency graph.
Workarounds
Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.
Frequently Asked Questions
Is GHSA-mmcv-fvq8-r9x3 in your dependencies?
Find it across Packagist, including transitive dependencies.