Drupal core allows Exploiting Incorrectly Configured Access Control Security LevelsGHSA-mhpg-hpj5-73r2
LOWGHSA-mhpg-hpj5-73r2 is a low-severity (CVSS 3.7) CWE-525 vulnerability in drupal/core. A fix is available for drupal/core — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-mhpg-hpj5-73r2.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
drupal/core🐘drupal/core🐘drupal/core🐘drupal/core🐘drupal/coreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Use of Web Browser Cache Containing Sensitive Information vulnerability in Drupal Drupal core allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Drupal core: from 8.0.0 before 10.4.9, from 10.5.0 before 10.5.6, from 11.0.0 before 11.1.9, from 11.2.0 before 11.2.8, from 7.0 before 7.103.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | drupal/core | ≥ 8.0.0&&< 10.4.9 | 10.4.9composer require drupal/core:^10.4.9 |
| 🐘Packagist | drupal/core | ≥ 10.5.0&&< 10.5.6 | 10.5.6composer require drupal/core:^10.5.6 |
| 🐘Packagist | drupal/core | ≥ 11.0.0&&< 11.1.9 | 11.1.9composer require drupal/core:^11.1.9 |
| 🐘Packagist | drupal/core | ≥ 11.2.0&&< 11.2.8 | 11.2.8composer require drupal/core:^11.2.8 |
| 🐘Packagist | drupal/core | ≥ 7.0&&< 7.103 | 7.103composer require drupal/core:^7.103 |
Affected Products
drupaldrupalDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for drupal/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update drupal/core to 10.4.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-mhpg-hpj5-73r2 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is GHSA-mhpg-hpj5-73r2 in your dependencies?
Find it across Packagist, including transitive dependencies.