NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
CRITICAL severity

NukeViet SQL Injection vulnerabilityGHSA-m8jx-mxf9-2rpw

CRITICALFix: nukeviet/module-shops@742c0e0

GHSA-m8jx-mxf9-2rpw is a critical-severity (CVSS 9.8) SQL Injection vulnerability in nukeviet/nukeviet. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for nukeviet/nukeviet — see the affected versions and patch details below.

Also known asCVE-2020-21809
Published
Updated
Affected
4 pkgs
Patched
3 / 4
Exploits
2 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs76th percentile — riskier than 76% of all scored CVEsHighest risk
0.09%0.75%1.41%2.08%0.6%1.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐘nukeviet/nukeviet🐘nukeviet/nukeviet🐘nukeviet/nukeviet🐘nukeviet/nukeviet

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

SQL Injection vulnerability in NukeViet CMS module Shops 4.0.29 and 4.3 via the (1) listid parameter in detail.php and the (2) group_price or groupid parameters in search_result.php.

Fix Implementation:

Download the update package corresponding to the NukeViet version you are using, extract and upload to hosting according to NukeViet's structure: For NukeViet 4.0 Official (4.0.29) For NukeViet 4.1 Official (4.1.02) For NukeViet 4.2 (4.2.01) As for NukeViet 4.3, you can update according to the notice in the admin page or see here: https://nukeviet.vn/vi/news/Tin-tuc/thong-bao-phat-hanh-nukeviet-4- 3-08-613.html

Affected Packages

4 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistnukeviet/nukeviet≥ 4.0&&< 4.0.294.0.29composer require nukeviet/nukeviet:^4.0.29
🐘Packagistnukeviet/nukeviet≥ 4.1&&< 4.1.024.1.02composer require nukeviet/nukeviet:^4.1.02
🐘Packagistnukeviet/nukeviet≥ 4.2&&< 4.2.014.2.01composer require nukeviet/nukeviet:^4.2.01
🐘Packagistnukeviet/nukevietall versionsNo fix

Affected Products

1 product · 1 configurations
Application
nukevietnukeviet
≥ 4.0.29 && ≤ 4.3
range
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for nukeviet/nukeviet, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update nukeviet/nukeviet to 4.0.29 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-m8jx-mxf9-2rpw is resolved across your whole dependency graph.

  3. Workarounds

    Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.

Frequently Asked Questions

SQL Injection vulnerability in NukeViet CMS module Shops 4.0.29 and 4.3 via the (1) listid parameter in detail.php and the (2) group_price or groupid parameters in search_result.php. ### Fix Implementation: Download the update package corresponding to the NukeViet version you are using, extract and upload to hosting according to NukeViet's structure: For NukeViet 4.0 Official (4.0.29) For NukeViet 4.1 Official (4.1.02) For NukeViet 4.2 (4.2.01) As for NukeViet 4.3, you can update according to the notice in the admin page or see here: https://nukeviet.vn/vi/news/Tin-tuc/thong-bao-phat-hanh-nu
O3 Security · Impact-Aware SCA

Is GHSA-m8jx-mxf9-2rpw in your dependencies?

Find it across Packagist, including transitive dependencies.

NukeViet SQL Injection vulnerability (Critical 9.8)