CVE-2020-21809 is a critical-severity (CVSS 9.8) SQL Injection vulnerability in nukeviet/nukeviet. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for nukeviet/nukeviet — see the affected versions and patch details below.
NukeViet SQL Injection vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
nukeviet/nukeviet🐘nukeviet/nukeviet🐘nukeviet/nukeviet🐘nukeviet/nukevietReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
SQL Injection vulnerability in NukeViet CMS module Shops 4.0.29 and 4.3 via the (1) listid parameter in detail.php and the (2) group_price or groupid parameters in search_result.php.
Fix Implementation:
Download the update package corresponding to the NukeViet version you are using, extract and upload to hosting according to NukeViet's structure: For NukeViet 4.0 Official (4.0.29) For NukeViet 4.1 Official (4.1.02) For NukeViet 4.2 (4.2.01) As for NukeViet 4.3, you can update according to the notice in the admin page or see here: https://nukeviet.vn/vi/news/Tin-tuc/thong-bao-phat-hanh-nukeviet-4- 3-08-613.html
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | nukeviet/nukeviet | ≥ 4.0&&< 4.0.29 | 4.0.29composer require nukeviet/nukeviet:^4.0.29 |
| 🐘Packagist | nukeviet/nukeviet | ≥ 4.1&&< 4.1.02 | 4.1.02composer require nukeviet/nukeviet:^4.1.02 |
| 🐘Packagist | nukeviet/nukeviet | ≥ 4.2&&< 4.2.01 | 4.2.01composer require nukeviet/nukeviet:^4.2.01 |
| 🐘Packagist | nukeviet/nukeviet | all versions | No fix |
Affected Products
nukevietnukevietResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for nukeviet/nukeviet, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update nukeviet/nukeviet to 4.0.29 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-21809 is resolved across your whole dependency graph.
Workarounds
Until you can upgrade, make sure every query built from user input uses parameterised statements or a prepared-statement API rather than string concatenation, and reduce the database account's privileges so an injected query cannot read or alter data beyond what the feature needs.
Frequently Asked Questions
Is CVE-2020-21809 in your dependencies?
Find it across Packagist, including transitive dependencies.