Mongoose search injection vulnerabilityGHSA-m7xq-9374-9rvx
CRITICALFix: github/advisory-database#6769GHSA-m7xq-9374-9rvx is a critical-severity (CVSS 9.8) SQL Injection vulnerability in mongoose. A fix is available for mongoose — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-m7xq-9374-9rvx.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
mongoosenpmDescription
Mongoose versions prior to 8.8.3, 7.8.3, 6.13.5, and 5.13.23 are vulnerable to improper use of the $where operator. This vulnerability arises from the ability of the $where clause to execute arbitrary JavaScript code in MongoDB queries, potentially leading to code injection attacks and unauthorized access or manipulation of database data.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | mongoose | ≥ 8.0.0-rc0&&< 8.8.3 | 8.8.3npm install mongoose@8.8.3 |
| 📦npm | mongoose | ≥ 7.0.0-rc0&&< 7.8.3 | 7.8.3npm install mongoose@7.8.3 |
| 📦npm | mongoose | ≥ 6.0.0-rc0&&< 6.13.5 | 6.13.5npm install mongoose@6.13.5 |
| 📦npm | mongoose | ≥ 3.6.0-rc0&&< 5.13.23 | 5.13.23npm install mongoose@5.13.23 |
Affected Products
mongoosemongoosejsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mongoose, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update mongoose to 8.8.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-m7xq-9374-9rvx is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
How to detect GHSA-m7xq-9374-9rvx
A community-maintained Nuclei template exists for this CVE. You can scan for it directly:
nuclei -id ghsa-m7xq-9374-9rvx -u https://target- Template
- Mongoose < 8.8.3 - Remote Code Execution
- Severity
- critical
- Impact
- Unauthenticated attackers can execute arbitrary code by exploiting NoSQL injection in the $where clause, allowing remote code execution via crafted query parameters.
- Remediation
- Update Mongoose to version 8.8.3 or later to address the NoSQL injection vulnerability.
Template by ProjectDiscovery nuclei-templates (h4mg), MIT licensed. View the full template. Scan only systems you are authorised to test.
Frequently Asked Questions
Is GHSA-m7xq-9374-9rvx in your dependencies?
Find it across npm, including transitive dependencies.