NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
CRITICAL severity

CVE-2024-53900 — mongoose

CRITICALFix: Automattic/mongoose@c9e86bf

CVE-2024-53900 is a critical-severity (CVSS 9.1) SQL Injection vulnerability in mongoose. A fix is available for mongoose — see the affected versions and patch details below.

Mongoose search injection vulnerability

Also known asBIT-mongoose-2024-53900GHSA-m7xq-9374-9rvx
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-53900.

EPSS Exploitation Probability

via FIRST.org ↗
4.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs91th percentile — riskier than 91% of all scored CVEsHighest risk
0.00%27.4%54.8%82.2%64.2%4.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

21Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
mongoosenpm
8.9Mdownloads / week

Description

Mongoose versions prior to 8.8.3, 7.8.3, 6.13.5, and 5.13.23 are vulnerable to improper use of the $where operator. This vulnerability arises from the ability of the $where clause to execute arbitrary JavaScript code in MongoDB queries, potentially leading to code injection attacks and unauthorized access or manipulation of database data.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
📦npmmongoose≥ 8.0.0-rc0&&< 8.8.38.8.3npm install mongoose@8.8.3
📦npmmongoose≥ 7.0.0-rc0&&< 7.8.37.8.3npm install mongoose@7.8.3
📦npmmongoose≥ 6.0.0-rc0&&< 6.13.56.13.5npm install mongoose@6.13.5
📦npmmongoose≥ 3.6.0-rc0&&< 5.13.235.13.23npm install mongoose@5.13.23

Affected Products

1 product · 5 configurations
Application
mongoosemongoosejs
≥ 8.0.1 && < 8.8.3
2 versions
7.0.08.0.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mongoose, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update mongoose to 8.8.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-53900 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

How to detect CVE-2024-53900

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2024-53900 -u https://target
Template
Mongoose < 8.8.3 - Remote Code Execution
Severity
critical
Impact
Unauthenticated attackers can execute arbitrary code by exploiting NoSQL injection in the $where clause, allowing remote code execution via crafted query parameters.
Remediation
Update Mongoose to version 8.8.3 or later to address the NoSQL injection vulnerability.

Template by ProjectDiscovery nuclei-templates (h4mg), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

Mongoose versions prior to 8.8.3, 7.8.3, 6.13.5, and 5.13.23 are vulnerable to improper use of the $where operator. This vulnerability arises from the ability of the $where clause to execute arbitrary JavaScript code in MongoDB queries, potentially leading to code injection attacks and unauthorized access or manipulation of database data.
O3 Security · Impact-Aware SCA

Is CVE-2024-53900 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2024-53900: mongoose RCE — Fixed in 8.8.3