NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
MEDIUM severity

KubeVela VelaUX APIserver has SSRF vulnerabilityGHSA-m5xf-x7q6-3rm7

MEDIUMFix: kubevela/kubevela#5000

GHSA-m5xf-x7q6-3rm7 is a medium-severity (CVSS 4.9) Server-Side Request Forgery (SSRF) vulnerability in github.com/oam-dev/kubevela. A fix is available for github.com/oam-dev/kubevela — see the affected versions and patch details below.

Also known asCVE-2022-39383GO-2022-1113
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-m5xf-x7q6-3rm7.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs37th percentile — riskier than 37% of all scored CVEsHighest risk
0.00%0.31%0.61%0.92%0.2%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐹github.com/oam-dev/kubevela🐹github.com/oam-dev/kubevela

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Impact

Users using the VelaUX APIServer could be affected by this vulnerability.

When using Helm Chart as the component delivery method, the request address of the warehouse is not restricted, and there is a blind SSRF vulnerability.

This issue is patched in 1.5.9 and 1.6.2.

References

Fix by: #5000

For more information

If you have any questions or comments about this advisory:

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/oam-dev/kubevela≥ 1.6.0-alpha.1&&< 1.6.21.6.2go get github.com/oam-dev/kubevela@v1.6.2
🐹Gogithub.com/oam-dev/kubevelaall versions1.5.9go get github.com/oam-dev/kubevela@v1.5.9

Affected Products

1 product · 2 configurations
Application
kubevelalinuxfoundation
≥ 1.6.0 && < 1.6.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/oam-dev/kubevela, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/oam-dev/kubevela to 1.6.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-m5xf-x7q6-3rm7 is resolved across your whole dependency graph.

  3. Workarounds

    Restrict outbound requests from the affected component to an allowlist of hosts, block access to link-local and internal address ranges at the network layer, and require authentication on internal services so a forged request cannot reach them unauthenticated.

Frequently Asked Questions

### Impact Users using the VelaUX APIServer could be affected by this vulnerability. When using Helm Chart as the component delivery method, the request address of the warehouse is not restricted, and there is a blind SSRF vulnerability. This issue is patched in 1.5.9 and 1.6.2. ### References Fix by: #5000 ### For more information If you have any questions or comments about this advisory: * Open an issue in [KubeVela repo](https://github.com/kubevela/kubevela) * Email us at [here](https://github.com/kubevela/kubevela#contact-us)
O3 Security · Impact-Aware SCA

Is GHSA-m5xf-x7q6-3rm7 in your dependencies?

Find it across Go, including transitive dependencies.

KubeVela VelaUX APIserver has SSRF vulnerability