CVE-2022-39383 is a medium-severity (CVSS 4.9) Server-Side Request Forgery (SSRF) vulnerability in github.com/oam-dev/kubevela. A fix is available for github.com/oam-dev/kubevela — see the affected versions and patch details below.
SSRF vulnerability in KubeVela VelaUX APIServer
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-39383.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/oam-dev/kubevela🐹github.com/oam-dev/kubevelaReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Impact
Users using the VelaUX APIServer could be affected by this vulnerability.
When using Helm Chart as the component delivery method, the request address of the warehouse is not restricted, and there is a blind SSRF vulnerability.
This issue is patched in 1.5.9 and 1.6.2.
References
Fix by: #5000
For more information
If you have any questions or comments about this advisory:
- Open an issue in KubeVela repo
- Email us at here
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/oam-dev/kubevela | ≥ 1.6.0-alpha.1&&< 1.6.2 | 1.6.2go get github.com/oam-dev/kubevela@v1.6.2 |
| 🐹Go | github.com/oam-dev/kubevela | all versions | 1.5.9go get github.com/oam-dev/kubevela@v1.5.9 |
Affected Products
kubevelalinuxfoundationDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/oam-dev/kubevela, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/oam-dev/kubevela to 1.6.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-39383 is resolved across your whole dependency graph.
Workarounds
Restrict outbound requests from the affected component to an allowlist of hosts, block access to link-local and internal address ranges at the network layer, and require authentication on internal services so a forged request cannot reach them unauthenticated.
Frequently Asked Questions
Is CVE-2022-39383 in your dependencies?
Find it across Go, including transitive dependencies.