Flowise and Flowise Chat Embed vulnerable to Stored Cross-site ScriptingGHSA-m5p9-xvxj-64c8
CRITICALFix: FlowiseAI/Flowise@8375ebbGHSA-m5p9-xvxj-64c8 is a critical-severity (CVSS 9.6) Cross-site Scripting (XSS) vulnerability in flowise-embed. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for flowise-embed — see the affected versions and patch details below.
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- A successful exploit gives an attacker total control of the affected component, not partial access.
Exploitation and automatability from CISA’s SSVC triage for GHSA-m5p9-xvxj-64c8.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
flowise-embednpmflowisenpmDescription
Flowise < 2.1.1 suffers from a Stored Cross-Site vulnerability due to a lack of input sanitization in Flowise Chat Embed < 2.0.0.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | flowise-embed | all versions | 2.0.0npm install flowise-embed@2.0.0 |
| 📦npm | flowise | all versions | 2.1.1npm install flowise@2.1.1 |
Affected Products
embedflowiseaiflowiseflowiseaiResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for flowise-embed, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update flowise-embed to 2.0.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-m5p9-xvxj-64c8 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-m5p9-xvxj-64c8 in your dependencies?
Find it across npm, including transitive dependencies.