NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
CRITICAL severity

CVE-2024-9148 — flowise-embed

CRITICALFix: FlowiseAI/Flowise@8375ebb

CVE-2024-9148 is a critical-severity (CVSS 9.6) Cross-site Scripting (XSS) vulnerability in flowise-embed. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for flowise-embed — see the affected versions and patch details below.

Flowise Stored Cross-Site Scripting

Also known asGHSA-m5p9-xvxj-64c8
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
1 known
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA’s SSVC triage for CVE-2024-9148.

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs47th percentile — riskier than 47% of all scored CVEsHighest risk
0.06%0.85%1.64%2.43%1.9%0.6%May 26Sep 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

11other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
flowise-embednpm
8Kdownloads / week
flowisenpm
5Kdownloads / week

Description

Flowise < 2.1.1 suffers from a Stored Cross-Site vulnerability due to a lack of input sanitization in Flowise Chat Embed < 2.0.0.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
📦npmflowise-embedall versions2.0.0npm install flowise-embed@2.0.0
📦npmflowiseall versions2.1.1npm install flowise@2.1.1

Affected Products

2 products · 2 configurations
Application
embedflowiseai
< 2.0.0
range
Application
flowiseflowiseai
< 2.1.1
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for flowise-embed, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update flowise-embed to 2.0.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2024-9148 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Flowise < 2.1.1 suffers from a Stored Cross-Site vulnerability due to a lack of input sanitization in Flowise Chat Embed < 2.0.0.
O3 Security · Impact-Aware SCA

Is CVE-2024-9148 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2024-9148: flowise-embed — Fixed in 2.0.0