Agno: Arbitrary code execution via `eval()` on `field_type` in `FunctionCall`GHSA-m4w4-3r8h-jw98
CRITICALFix: agno-agi/agno@cbf6755GHSA-m4w4-3r8h-jw98 is a critical-severity (CVSS 9.8) CWE-95 vulnerability in agno. A fix is available for agno — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-m4w4-3r8h-jw98.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
agnoReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Impact
Agno versions prior to 2.3.24 contain an arbitrary code execution vulnerability
in the model execution component. The field_type parameter on a FunctionCall
input field was passed to Python's built-in eval(), allowing an attacker who
could influence that value to execute arbitrary Python code in the Agno process.
This is a code injection flaw (CWE-95) with full impact to confidentiality, integrity, and availability. CVSS 3.1 score: 9.3 (Critical).
Any deployment that exposes Agno to user-influenced FunctionCall inputs (for example via an API, web UI, or untrusted tool/model output) is affected.
Patches
Fixed in Agno 2.3.24.
The unsafe eval() call was replaced with a fixed type_mapping dictionary
lookup, and field_type is now validated as either a known string key or an
already-resolved type object before use. See commit
cbf67552
(PR #5912).
All users should upgrade to 2.3.24 or later. The current release line (2.6.x) includes the fix.
Workarounds
There is no safe workaround. Users who cannot upgrade should ensure no
untrusted input can reach the field_type parameter of FunctionCall
input fields, but upgrading is strongly preferred.
References
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | agno | all versions | 2.3.24pip install --upgrade 'agno==2.3.24' |
Affected Products
agnoagnoDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for agno, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update agno to 2.3.24 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-m4w4-3r8h-jw98 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is GHSA-m4w4-3r8h-jw98 in your dependencies?
Find it across PyPI, including transitive dependencies.