NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

django-helpdesk Allows Sensitive Data ExposureGHSA-m4jx-m5hg-qrxx

MEDIUMFix: django-helpdesk/django-helpdesk#1120

GHSA-m4jx-m5hg-qrxx is a medium-severity (CVSS 5.1) CWE-277 vulnerability in django-helpdesk. A fix is available for django-helpdesk — see the affected versions and patch details below.

Also known asCVE-2018-25111PYSEC-2025-44
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for GHSA-m4jx-m5hg-qrxx.

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs12th percentile — riskier than 12% of all scored CVEsHighest risk
0.00%0.24%0.48%0.71%0.1%0.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍django-helpdesk

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

django-helpdesk before 1.0.0 allows Sensitive Data Exposure because of os.umask(0) in models.py.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIdjango-helpdeskall versions1.0.0pip install --upgrade 'django-helpdesk==1.0.0'

Affected Products

1 product · 1 configurations
Application
django-helpdeskdjango-helpdesk_project
< 1.0.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for django-helpdesk, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update django-helpdesk to 1.0.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-m4jx-m5hg-qrxx is resolved across your whole dependency graph.

  3. Workarounds

    Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.

Frequently Asked Questions

django-helpdesk before 1.0.0 allows Sensitive Data Exposure because of os.umask(0) in models.py.
O3 Security · Impact-Aware SCA

Is GHSA-m4jx-m5hg-qrxx in your dependencies?

Find it across PyPI, including transitive dependencies.

django-helpdesk Allows Sensitive Data Exposure