NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2018-25111 — django-helpdesk

MEDIUMFix: django-helpdesk/django-helpdesk#1120

CVE-2018-25111 is a medium-severity (CVSS 4.4) CWE-277 vulnerability in django-helpdesk. A fix is available for django-helpdesk — see the affected versions and patch details below.

django-helpdesk Allows Sensitive Data Exposure

Also known asGHSA-m4jx-m5hg-qrxxPYSEC-2025-44
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 23, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for CVE-2018-25111.

EPSS Exploitation Probability

via FIRST.org ↗
0.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs10th percentile — riskier than 10% of all scored CVEsHighest risk
0.00%0.24%0.47%0.71%0.1%0.2%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍django-helpdesk

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

django-helpdesk before 1.0.0 allows Sensitive Data Exposure because of os.umask(0) in models.py.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIdjango-helpdeskall versions1.0.0pip install --upgrade 'django-helpdesk==1.0.0'

Affected Products

1 product · 1 configurations
Application
django-helpdeskdjango-helpdesk_project
< 1.0.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for django-helpdesk, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update django-helpdesk to 1.0.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2018-25111 is resolved across your whole dependency graph.

  3. Workarounds

    Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.

Frequently Asked Questions

django-helpdesk before 1.0.0 allows Sensitive Data Exposure because of os.umask(0) in models.py.
O3 Security · Impact-Aware SCA

Is CVE-2018-25111 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2018-25111: django-helpdesk — Fixed in 1.0.0