NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
CRITICAL severity

Prototype Pollution in madlib-object-utilsGHSA-jvf5-q4h5-2jmj

CRITICALFix: Qwerios/madlib-object-utils@2a8d5be

GHSA-jvf5-q4h5-2jmj is a critical-severity (CVSS 9.8) CWE-1321 vulnerability in madlib-object-utils. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for madlib-object-utils — see the affected versions and patch details below.

Also known asCVE-2020-7701SNYK-JS-MADLIBOBJECTUTILS-598676
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs81th percentile — riskier than 81% of all scored CVEsHighest risk
0.60%1.25%1.90%2.56%1.1%2.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, a proxy for how much of the ecosystem is exposed.

madlib-object-utilsnpm
94downloads / week

Description

madlib-object-utils before 0.1.7 is vulnerable to Prototype Pollution via setValue.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmmadlib-object-utilsall versions0.1.7npm install madlib-object-utils@0.1.7

Affected Products

1 product · 1 configurations
Application
madlib-object-utilsspringtree
< 0.1.7
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for madlib-object-utils, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update madlib-object-utils to 0.1.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-jvf5-q4h5-2jmj is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

madlib-object-utils before 0.1.7 is vulnerable to Prototype Pollution via setValue.
O3 Security · Impact-Aware SCA

Is GHSA-jvf5-q4h5-2jmj in your dependencies?

Find it across npm, including transitive dependencies.

Prototype Pollution in madlib-object-utils (Critical 9.8)