TYPO3 Brute Force Protection Bypass in backend loginGHSA-jqr8-q455-xx45
MEDIUMFix: TYPO3/typo3@0b67290GHSA-jqr8-q455-xx45 is a medium-severity (CVSS 6.5) vulnerability in typo3/cms. A fix is available for typo3/cms — see the affected versions and patch details below.
Real-World Exposure
typo3/cms🐘typo3/cmsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
The backend login has a basic brute force protection implementation which pauses for 5 seconds if wrong credentials are given. This pause however could be bypassed by forging a special request, making brute force attacks on backend editor credentials more feasible.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | typo3/cms | ≥ 6.2.0&&< 6.2.14 | 6.2.14composer require typo3/cms:^6.2.14 |
| 🐘Packagist | typo3/cms | ≥ 7.0.0&&< 7.3.1 | 7.3.1composer require typo3/cms:^7.3.1 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update typo3/cms to 6.2.14 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-jqr8-q455-xx45 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-jqr8-q455-xx45 in your dependencies?
Find it across Packagist, including transitive dependencies.