Buildbot Cross-site scripting (XSS) vulnerabilityGHSA-jqqh-999x-w26w
MEDIUMFix: buildbot/buildbot@a08ee48GHSA-jqqh-999x-w26w is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in buildbot. A fix is available for buildbot — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
buildbotReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Cross-site scripting (XSS) vulnerability in the waterfall web status view (status/web/waterfall.py) in Buildbot 0.7.6 through 0.7.11p1 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | buildbot | ≥ 0.7.6&&< 0.7.11p3 | 0.7.11p3pip install --upgrade 'buildbot==0.7.11p3' |
Affected Products
buildbotbuildbotDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for buildbot, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update buildbot to 0.7.11p3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-jqqh-999x-w26w is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-jqqh-999x-w26w in your dependencies?
Find it across PyPI, including transitive dependencies.