NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2009-2967 — buildbot

MEDIUMFix: buildbot/buildbot@78f7942

CVE-2009-2967 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in buildbot. A fix is available for buildbot — see the affected versions and patch details below.

Buildbot vulnerable to cross-site scripting

Also known asGHSA-mj3x-wprp-mvj9PYSEC-2009-2
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs83th percentile — riskier than 83% of all scored CVEsHighest risk
0.10%0.99%1.88%2.77%0.6%2.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍buildbot

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Multiple cross-site scripting (XSS) vulnerabilities in Buildbot 0.7.6 through 0.7.11p2 allow remote attackers to inject arbitrary web script or HTML via unspecified vectors, different vulnerabilities than CVE-2009-2959.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIbuildbot≥ 0.7.6&&< 0.7.11p30.7.11p3pip install --upgrade 'buildbot==0.7.11p3'

Affected Products

1 product · 9 configurations
Application
buildbotbuildbot
9 versions
0.7.60.7.70.7.80.7.90.7.100.7.10p10.7.110.7.11p10.7.11p2

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for buildbot, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update buildbot to 0.7.11p3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2009-2967 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Multiple cross-site scripting (XSS) vulnerabilities in Buildbot 0.7.6 through 0.7.11p2 allow remote attackers to inject arbitrary web script or HTML via unspecified vectors, different vulnerabilities than CVE-2009-2959.
O3 Security · Impact-Aware SCA

Is CVE-2009-2967 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2009-2967: buildbot XSS — Fixed in 0.7.11p3