NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

Cross-site Scripting in modoboaGHSA-jm3m-wr3p-hjrq

HIGHFix: modoboa/modoboa@eef9ab7

GHSA-jm3m-wr3p-hjrq is a high-severity (CVSS 7.1) Cross-site Scripting (XSS) vulnerability in modoboa. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for modoboa — see the affected versions and patch details below.

Also known asCVE-2023-0519PYSEC-2023-31
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for GHSA-jm3m-wr3p-hjrq.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk+0.01%
Lower risk than most CVEs44th percentile — riskier than 44% of all scored CVEsHighest risk
0.00%0.34%0.68%1.02%0.2%0.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍modoboa

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Cross-site Scripting (XSS) - Stored in GitHub repository modoboa/modoboa prior to 2.0.4.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPImodoboaall versions2.0.4pip install --upgrade 'modoboa==2.0.4'

Affected Products

1 product · 1 configurations
Application
modoboamodoboa
< 2.0.4
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for modoboa, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update modoboa to 2.0.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-jm3m-wr3p-hjrq is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross-site Scripting (XSS) - Stored in GitHub repository modoboa/modoboa prior to 2.0.4.
O3 Security · Impact-Aware SCA

Is GHSA-jm3m-wr3p-hjrq in your dependencies?

Find it across PyPI, including transitive dependencies.

Cross-site Scripting in modoboa (High 7.1)