NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
LOW severity

Flask-AppBuilder vulnerable to possible disclosure of sensitive information on user errorGHSA-jhpr-j7cq-3jp3

LOWFix: dpgaspar/Flask-AppBuilder#2045

GHSA-jhpr-j7cq-3jp3 is a low-severity (CVSS 2.7) CWE-209 vulnerability in flask-appbuilder. A fix is available for flask-appbuilder — see the affected versions and patch details below.

Also known asCVE-2023-34110PYSEC-2023-94
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-jhpr-j7cq-3jp3.

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs52th percentile — riskier than 52% of all scored CVEsHighest risk
0.00%0.39%0.78%1.18%0.5%0.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍flask-appbuilder

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Flask-AppBuilder is an application development framework, built on top of Flask. Prior to version 4.3.2, an authenticated malicious actor with Admin privileges, could by adding a special character on the add, edit User forms trigger a database error, this error is surfaced back to this actor on the UI. On certain database engines this error can include the entire user row including the pbkdf2:sha256 hashed password. This vulnerability has been fixed in version 4.3.2.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIflask-appbuilderall versions4.3.2pip install --upgrade 'flask-appbuilder==4.3.2'

Affected Products

1 product · 1 configurations
Application
flask-appbuilderflask-appbuilder_project
< 4.3.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for flask-appbuilder, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update flask-appbuilder to 4.3.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-jhpr-j7cq-3jp3 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Impact An authenticated malicious actor with Admin privileges, could by adding a special character on the add, edit User forms trigger a database error, this error is surfaced back to this actor on the UI. On certain database engines this error can include the entire user row including the pbkdf2:sha256 hashed password. ### Patches Fixed on 4.3.2
O3 Security · Impact-Aware SCA

Is GHSA-jhpr-j7cq-3jp3 in your dependencies?

Find it across PyPI, including transitive dependencies.

Flask-AppBuilder vulnerable to possible disclosure of…