ImageMagick: Memory Leak in TIFF encoder when an allocation failsGHSA-jfq9-q63x-rc63
LOWGHSA-jfq9-q63x-rc63 is a low-severity (CVSS 2.9) CWE-401 vulnerability in Magick.NET-Q16-AnyCPU. A fix is available for Magick.NET-Q16-AnyCPU — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-jfq9-q63x-rc63.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
GHSA-jfq9-q63x-rc63 by exploitation likelihood (EPSS) against impact (CVSS). Outside the shaded patch-first corner.
Where this sits among everything scored
Of 395,492 CVEs with a current EPSS score, this one falls in the < 10% band (highlighted). Counts from FIRST.org, log-scaled.
Real-World Exposure
Magick.NET-Q16-AnyCPU.NETMagick.NET-Q16-HDRI-AnyCPU.NETMagick.NET-Q16-HDRI-OpenMP-arm64.NETMagick.NET-Q16-HDRI-x64.NETMagick.NET-Q16-HDRI-x86.NETMagick.NET-Q16-OpenMP-arm64.NETMagick.NET-Q16-OpenMP-x64.NETMagick.NET-Q16-arm64+9 moreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects NuGet packages — download data is not available via public APIs for these ecosystems.
Description
ImageMagick before 7.1.2-26 contains a memory leak vulnerability in the TIFF encoder when memory allocation fails. Attackers can trigger allocation failures during TIFF image processing to cause memory exhaustion and denial of service.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| .NETNuGet | Magick.NET-Q16-AnyCPU | all versions | 14.15.0dotnet add package Magick.NET-Q16-AnyCPU --version 14.15.0 |
| .NETNuGet | Magick.NET-Q16-HDRI-AnyCPU | all versions | 14.15.0dotnet add package Magick.NET-Q16-HDRI-AnyCPU --version 14.15.0 |
| .NETNuGet | Magick.NET-Q16-HDRI-OpenMP-arm64 | all versions | 14.15.0dotnet add package Magick.NET-Q16-HDRI-OpenMP-arm64 --version 14.15.0 |
| .NETNuGet | Magick.NET-Q16-HDRI-x64 | all versions | 14.15.0dotnet add package Magick.NET-Q16-HDRI-x64 --version 14.15.0 |
| .NETNuGet | Magick.NET-Q16-HDRI-x86 | all versions | 14.15.0dotnet add package Magick.NET-Q16-HDRI-x86 --version 14.15.0 |
| .NETNuGet | Magick.NET-Q16-OpenMP-arm64 | all versions | 14.15.0dotnet add package Magick.NET-Q16-OpenMP-arm64 --version 14.15.0 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for Magick.NET-Q16-AnyCPU, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update Magick.NET-Q16-AnyCPU to 14.15.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-jfq9-q63x-rc63 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Red Hat Enterprise Linux ships ImageMagick in RHEL 6 ELS and RHEL 7 ELS. This flaw has been rated as having a Low security impact and is not currently planned to be addressed in future updates of those products. For additional information, refer to the Issue Severity Classification:…
Do not process untrusted image files with ImageMagick. If processing of untrusted input is required, configure ImageMagick's policy.xml to set memory and map resource limits to contain the impact of potential memory leaks. Upgrade to ImageMagick 7.1.2-26 or 6.9.13-51 mitigates the issue.Source: Red Hat security advisory for GHSA-jfq9-q63x-rc63 (CC BY 4.0)
Frequently Asked Questions
Is GHSA-jfq9-q63x-rc63 in your dependencies?
Find it across NuGet, including transitive dependencies.