NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

Silverstripe Form field validation message XSS vulnerabilityGHSA-j982-5jv7-v43r

MEDIUMFix: silverstripe/silverstripe-framework@245e0aa

GHSA-j982-5jv7-v43r is a medium-severity (CVSS 6.1) vulnerability in silverstripe/framework. A fix is available for silverstripe/framework — see the affected versions and patch details below.

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 28, 2024 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

2 pkgs affected
🐘silverstripe/framework🐘silverstripe/framework

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

A high level XSS risk has been identified in the encoding of validation messages in certain FormField classes.

Certain fields such as the NumericField and DropdownField have been identified, but any form field which presents any invalid content as a part of its validation response will be at risk.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistsilverstripe/framework≥ 3.0.0&&< 3.1.163.1.16composer require silverstripe/framework:^3.1.16
🐘Packagistsilverstripe/framework≥ 3.2.0&&< 3.2.13.2.1composer require silverstripe/framework:^3.2.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for silverstripe/framework, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update silverstripe/framework to 3.1.16 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-j982-5jv7-v43r is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

A high level XSS risk has been identified in the encoding of validation messages in certain FormField classes. Certain fields such as the NumericField and DropdownField have been identified, but any form field which presents any invalid content as a part of its validation response will be at risk.
O3 Security · Impact-Aware SCA

Is GHSA-j982-5jv7-v43r in your dependencies?

Find it across Packagist, including transitive dependencies.

Silverstripe Form field validation message XSS vulnerability