NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

Apiman has potential permissions bypassGHSA-j94p-hv25-rm5g

HIGH

GHSA-j94p-hv25-rm5g is a high-severity (CVSS 7.1) Incorrect Default Permissions vulnerability in io.apiman:apiman-manager-api-rest-impl. A fix is available for io.apiman:apiman-manager-api-rest-impl — see the affected versions and patch details below.

Also known asCVE-2022-47551
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-j94p-hv25-rm5g.

EPSS Exploitation Probability

via FIRST.org ↗
0.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs51th percentile — riskier than 51% of all scored CVEsHighest risk
0.00%0.38%0.76%1.14%0.1%0.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕io.apiman:apiman-manager-api-rest-impl

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Impact

Incorrect default permissions for certain read-only resources in the Apiman 1.5.7.Final through 2.2.3.Final in the Apiman Manager REST API allows a remote authenticated attacker to access information and resources in an Apiman Organizations they are not a member of and/or do not have permissions for.

For example, an attacker may be able to craft an HTTP request to discover APIs that are private to organizations they are not members of, via fuzzing, search, and other similar mechanisms.

If the attacker has sufficient permissions in their own organization, they may also be able to sign up to the private APIs they have discovered by crafting a tailored HTTP request, thereby gaining access to an API Management protected resource that they should have access to.

  • A malicious account-holder may be able to see information about APIs they do not have permission for.

  • A malicious account-holder may be able to sign up to APIs they do not have permission for, and hence access API Management-protected resources they are not authorized to access.

  • This does NOT relate to the Apiman Gateway.

Patches

  • Upgrade to Apiman 3.0.0.Final (or later). The issue is fixed in this version.

  • If you are using an older version of Apiman, contact to your Apiman support provider for advice/long-term support.

References

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenio.apiman:apiman-manager-api-rest-impl≥ 1.5.7&&< 3.0.0.Final3.0.0.Finalio.apiman:apiman-manager-api-rest-impl:3.0.0.Final

Affected Products

1 product · 1 configurations
Application
apimanapiman
≥ 1.5.7 && ≤ 2.2.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for io.apiman:apiman-manager-api-rest-impl, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update io.apiman:apiman-manager-api-rest-impl to 3.0.0.Final or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-j94p-hv25-rm5g is resolved across your whole dependency graph.

  3. Workarounds

    Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.

Frequently Asked Questions

### Impact Incorrect default permissions for certain read-only resources in the Apiman 1.5.7.Final through 2.2.3.Final in the Apiman Manager REST API allows a remote authenticated attacker to access information and resources in an Apiman Organizations they are not a member of and/or do not have permissions for. For example, an attacker may be able to craft an HTTP request to discover APIs that are private to organizations they are not members of, via fuzzing, search, and other similar mechanisms. If the attacker has sufficient permissions in their own organization, they may also be able to
O3 Security · Impact-Aware SCA

Is GHSA-j94p-hv25-rm5g in your dependencies?

Find it across Maven, including transitive dependencies.

Apiman has potential permissions bypass (High 7.1)