CVE-2022-47551 — apiman-manager-api-rest-i…
MEDIUMCVE-2022-47551 is a medium-severity (CVSS 6.5) Incorrect Default Permissions vulnerability in io.apiman:apiman-manager-api-rest-impl. A fix is available for io.apiman:apiman-manager-api-rest-impl — see the affected versions and patch details below.
Apiman has potential permissions bypass
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2022-47551.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
io.apiman:apiman-manager-api-rest-implReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Impact
Incorrect default permissions for certain read-only resources in the Apiman 1.5.7.Final through 2.2.3.Final in the Apiman Manager REST API allows a remote authenticated attacker to access information and resources in an Apiman Organizations they are not a member of and/or do not have permissions for.
For example, an attacker may be able to craft an HTTP request to discover APIs that are private to organizations they are not members of, via fuzzing, search, and other similar mechanisms.
If the attacker has sufficient permissions in their own organization, they may also be able to sign up to the private APIs they have discovered by crafting a tailored HTTP request, thereby gaining access to an API Management protected resource that they should have access to.
-
A malicious account-holder may be able to see information about APIs they do not have permission for.
-
A malicious account-holder may be able to sign up to APIs they do not have permission for, and hence access API Management-protected resources they are not authorized to access.
-
This does NOT relate to the Apiman Gateway.
Patches
-
Upgrade to Apiman 3.0.0.Final (or later). The issue is fixed in this version.
-
If you are using an older version of Apiman, contact to your Apiman support provider for advice/long-term support.
References
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | io.apiman:apiman-manager-api-rest-impl | ≥ 1.5.7&&< 3.0.0.Final | 3.0.0.Finalio.apiman:apiman-manager-api-rest-impl:3.0.0.Final |
Affected Products
apimanapimanDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for io.apiman:apiman-manager-api-rest-impl, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update io.apiman:apiman-manager-api-rest-impl to 3.0.0.Final or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-47551 is resolved across your whole dependency graph.
Workarounds
Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.
Frequently Asked Questions
Is CVE-2022-47551 in your dependencies?
Find it across Maven, including transitive dependencies.