Cockpit - Content Platform vulnerable to XSS through name or email argument namesGHSA-j4rj-fgcq-wmqp
LOWFix: Cockpit-HQ/Cockpit@bdcd5e3GHSA-j4rj-fgcq-wmqp is a low-severity (CVSS 3.5) Cross-site Scripting (XSS) vulnerability in cockpit-hq/cockpit. A fix is available for cockpit-hq/cockpit — see the affected versions and patch details below.
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
Exploitation and automatability from CISA’s SSVC triage for GHSA-j4rj-fgcq-wmqp.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
cockpit-hq/cockpitReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
A vulnerability was found in Cockpit up to 2.11.3. It has been rated as problematic. This issue affects some unknown processing of the file /system/users/save. The manipulation of the argument name/email leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 2.11.4 is able to address this issue. The patch is named bdcd5e3bc651c0839c7eea807f3eb6af856dbc76. It is recommended to upgrade the affected component. The vendor was contacted early about this disclosure and acted very professional. A patch and new release was made available very quickly.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | cockpit-hq/cockpit | all versions | 2.11.4composer require cockpit-hq/cockpit:^2.11.4 |
Affected Products
cockpitagentejoDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for cockpit-hq/cockpit, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update cockpit-hq/cockpit to 2.11.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-j4rj-fgcq-wmqp is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is GHSA-j4rj-fgcq-wmqp in your dependencies?
Find it across Packagist, including transitive dependencies.