NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

Cross-site Scripting in NocoDBGHSA-hv6q-5g4f-8897

MEDIUMFix: nocodb/nocodb#2343

GHSA-hv6q-5g4f-8897 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in nocodb. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for nocodb — see the affected versions and patch details below.

Also known asCVE-2022-2079
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk+0.01%
Lower risk than most CVEs54th percentile — riskier than 54% of all scored CVEsHighest risk
0.00%0.41%0.82%1.22%0.4%0.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

0other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
nocodbnpm
14Kdownloads / week

Description

Cross-site Scripting (XSS) - Stored in GitHub repository nocodb/nocodb prior to 0.91.7+.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmnocodball versions0.91.9npm install nocodb@0.91.9

Affected Products

1 product · 1 configurations
Application
nocodbnocodb
< 0.91.7
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for nocodb, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update nocodb to 0.91.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-hv6q-5g4f-8897 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Cross-site Scripting (XSS) - Stored in GitHub repository nocodb/nocodb prior to 0.91.9.
O3 Security · Impact-Aware SCA

Is GHSA-hv6q-5g4f-8897 in your dependencies?

Find it across npm, including transitive dependencies.

Cross-site Scripting in NocoDB (Medium 5.4)