Jetty accepts "+" prefixed value in Content-LengthGHSA-hmr7-m48g-48f6
MEDIUMGHSA-hmr7-m48g-48f6 is a medium-severity (CVSS 5.3) CWE-130 vulnerability in org.eclipse.jetty:jetty-http. A fix is available for org.eclipse.jetty:jetty-http — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-hmr7-m48g-48f6.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.eclipse.jetty:jetty-http☕org.eclipse.jetty:jetty-http☕org.eclipse.jetty:jetty-http☕org.eclipse.jetty:jetty-httpReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Impact
Jetty accepts the '+' character proceeding the content-length value in a HTTP/1 header field. This is more permissive than allowed by the RFC and other servers routinely reject such requests with 400 responses. There is no known exploit scenario, but it is conceivable that request smuggling could result if jetty is used in combination with a server that does not close the connection after sending such a 400 response.
Workarounds
There is no workaround as there is no known exploit scenario.
Original Report
RFC 9110 Secion 8.6 defined the value of Content-Length header should be a string of 0-9 digits. However we found that Jetty accepts "+" prefixed Content-Length, which could lead to potential HTTP request smuggling.
Payload:
POST / HTTP/1.1
Host: a.com
Content-Length: +16
Connection: close
0123456789abcdef
When sending this payload to Jetty, it can successfully parse and identify the length.
When sending this payload to NGINX, Apache HTTPd or other HTTP servers/parsers, they will return 400 bad request.
This behavior can lead to HTTP request smuggling and can be leveraged to bypass WAF or IDS.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.eclipse.jetty:jetty-http | ≥ 9.0.0&&< 9.4.52 | 9.4.52org.eclipse.jetty:jetty-http:9.4.52 |
| ☕Maven | org.eclipse.jetty:jetty-http | ≥ 10.0.0&&< 10.0.16 | 10.0.16org.eclipse.jetty:jetty-http:10.0.16 |
| ☕Maven | org.eclipse.jetty:jetty-http | ≥ 11.0.0&&< 11.0.16 | 11.0.16org.eclipse.jetty:jetty-http:11.0.16 |
| ☕Maven | org.eclipse.jetty:jetty-http | ≥ 12.0.0&&< 12.0.1 | 12.0.1org.eclipse.jetty:jetty-http:12.0.1 |
Affected Products
debian linuxdebianjettyeclipseDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.eclipse.jetty:jetty-http, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.eclipse.jetty:jetty-http to 9.4.52 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-hmr7-m48g-48f6 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| OCP-Tools-4.12-RHEL-8 | jenkins-0:2.426.3.1706515686-3.el8 | RHSA-2024:0778 |
| Red Hat AMQ Broker 7 | jetty-http | RHSA-2023:5946 |
| Red Hat AMQ Clients | jetty-http | RHSA-2023:7697 |
| Red Hat AMQ Streams 2.6.0 | jetty-http | RHSA-2023:7678 |
| Red Hat Fuse 7.12.1 | jetty | RHSA-2023:7247 |
| Red Hat Fuse 7.13.0 | jetty | RHSA-2024:3354 |
| Red Hat Integration Camel Quarkus 2 | jetty-http | RHSA-2023:5780 |
| Red Hat Satellite 6.14 for RHEL 8 | candlepin-0:4.3.11-1.el8sat | RHSA-2024:0797 |
Frequently Asked Questions
Is GHSA-hmr7-m48g-48f6 in your dependencies?
Find it across Maven, including transitive dependencies.