CVE-2022-2047 — jetty-http
LOWCVE-2022-2047 is a low-severity (CVSS 2.7) Improper Input Validation vulnerability in org.eclipse.jetty:jetty-http. A fix is available for org.eclipse.jetty:jetty-http — see the affected versions and patch details below.
Jetty invalid URI parsing may produce invalid HttpURI.authority
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.eclipse.jetty:jetty-http☕org.eclipse.jetty:jetty-http☕org.eclipse.jetty:jetty-httpReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Description
URI use within Jetty's HttpURI class can parse invalid URIs such as http://localhost;/path as having an authority with a host of localhost;.
A URIs of the type http://localhost;/path should be interpreted to be either invalid or as localhost; to be the userinfo and no host.
However, HttpURI.host returns localhost; which is definitely wrong.
Impact
This can lead to errors with Jetty's HttpClient, and Jetty's ProxyServlet / AsyncProxyServlet / AsyncMiddleManServlet wrongly interpreting an authority with no host as one with a host.
Patches
Patched in PR #8146 for Jetty version 9.4.47. Patched in PR #8014 for Jetty versions 10.0.10, and 11.0.10
Workarounds
None.
For more information
If you have any questions or comments about this advisory:
- Email us at [email protected].
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.eclipse.jetty:jetty-http | all versions | 9.4.47org.eclipse.jetty:jetty-http:9.4.47 |
| ☕Maven | org.eclipse.jetty:jetty-http | ≥ 10.0.0&&< 10.0.10 | 10.0.10org.eclipse.jetty:jetty-http:10.0.10 |
| ☕Maven | org.eclipse.jetty:jetty-http | ≥ 11.0.0&&< 11.0.10 | 11.0.10org.eclipse.jetty:jetty-http:11.0.10 |
Affected Products
debian linuxdebianjettyeclipseelement plug-in for vcenter servernetapphci compute nodenetappmanagement services for element software and netapp hcinetappsnapcenternetappDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.eclipse.jetty:jetty-http, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.eclipse.jetty:jetty-http to 9.4.47 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2022-2047 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
In Red Hat Satellite jetty was used to build index files to search documentation. Nowadays in Satellite 6.9 and 6.10 jetty dependency is not in use and there is no access to it, so there is no way this vulnerability can be exploitable. Therefore Satellite supported versions are not affected.
| Product | Fixed in | Advisory |
|---|---|---|
| AMQ Broker 7.11.0 | jetty-http | RHSA-2023:1661 |
| Red Hat AMQ Streams 2.3.0 | jetty-http | RHSA-2023:0189 |
Frequently Asked Questions
Is CVE-2022-2047 in your dependencies?
Find it across Maven, including transitive dependencies.