org.xwiki.platform:xwiki-platform-livedata-macro vulnerable to Basic Cross-site ScriptingGHSA-hmm7-6ph9-8jf2
HIGHGHSA-hmm7-6ph9-8jf2 is a high-severity (CVSS 8.9) Cross-site Scripting (XSS) vulnerability in org.xwiki.platform:xwiki-platform-livedata-macro. A fix is available for org.xwiki.platform:xwiki-platform-livedata-macro — see the affected versions and patch details below.
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
- A successful exploit gives an attacker total control of the affected component, not partial access.
Exploitation and automatability from CISA’s SSVC triage for GHSA-hmm7-6ph9-8jf2.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.xwiki.platform:xwiki-platform-livedata-macro☕org.xwiki.platform:xwiki-platform-livedata-macro☕org.xwiki.platform:xwiki-platform-livedata-macroReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Impact
A user without script rights can introduce a stored XSS by using the Live Data macro, if the last author of the content of the page has script rights.
For instance, by adding the LiveData below in the about section of the profile of a user created by an admin.
{{liveData id="movies" properties="title,description"}}
{
"data": {
"count": 1,
"entries": [
{
"title": "Meet John Doe",
"url": "https://www.imdb.com/title/tt0033891/",
"description": "<img onerror='alert(1)' src='foo' />"
}
]
},
"meta": {
"propertyDescriptors": [
{
"id": "title",
"name": "Title",
"visible": true,
"displayer": {"id": "link", "propertyHref": "url"}
},
{
"id": "description",
"name": "Description",
"visible": true,
"displayer": "html"
}
]
}
}
{{/liveData}}
Patches
This has been patched in XWiki 14.10, 14.4.7, and 13.10.11.
Workarounds
No known workaround.
References
For more information
If you have any questions or comments about this advisory:
- Open an issue in Jira
- Email us at Security ML
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.xwiki.platform:xwiki-platform-livedata-macro | ≥ 13.10.10&&< 13.10.11 | 13.10.11org.xwiki.platform:xwiki-platform-livedata-macro:13.10.11 |
| ☕Maven | org.xwiki.platform:xwiki-platform-livedata-macro | ≥ 14.4&&< 14.4.7 | 14.4.7org.xwiki.platform:xwiki-platform-livedata-macro:14.4.7 |
| ☕Maven | org.xwiki.platform:xwiki-platform-livedata-macro | ≥ 14.9&&< 14.10 | 14.10org.xwiki.platform:xwiki-platform-livedata-macro:14.10 |
Affected Products
xwikixwikiDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.xwiki.platform:xwiki-platform-livedata-macro, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.xwiki.platform:xwiki-platform-livedata-macro to 13.10.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-hmm7-6ph9-8jf2 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-hmm7-6ph9-8jf2 in your dependencies?
Find it across Maven, including transitive dependencies.