silverstripe/framework has Cross-site Scripting vulnerability in page nameGHSA-hhvj-mcrx-3vcf
MEDIUMFix: silverstripe/silverstripe-framework@9574d62GHSA-hhvj-mcrx-3vcf is a medium-severity (CVSS 6.1) vulnerability in silverstripe/framework. A fix is available for silverstripe/framework — see the affected versions and patch details below.
Real-World Exposure
silverstripe/framework🐘silverstripe/frameworkReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
silverstripe/framework is vulnerable to XSS in Page name where the payload "><svg/onload=alert(/xss/)> will trigger an XSS alert.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | silverstripe/framework | ≥ 3.4.0-rc1&&< 3.4.4 | 3.4.4composer require silverstripe/framework:^3.4.4 |
| 🐘Packagist | silverstripe/framework | ≥ 3.5.0-rc1&&< 3.5.2 | 3.5.2composer require silverstripe/framework:^3.5.2 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for silverstripe/framework, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update silverstripe/framework to 3.4.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-hhvj-mcrx-3vcf is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-hhvj-mcrx-3vcf in your dependencies?
Find it across Packagist, including transitive dependencies.