NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘 Packagist
Not in CISA KEV

CakePHP Authentication: Open redirect weakness via backslash bypassGHSA-hhpq-7wg4-36jm

Fix: cakephp/authentication#795

GHSA-hhpq-7wg4-36jm is a Open Redirect vulnerability in cakephp/authentication. A fix is available for cakephp/authentication — see the affected versions and patch details below.

Also known asCVE-2026-55590
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-hhpq-7wg4-36jm.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs42th percentile — riskier than 42% of all scored CVEsHighest risk
0.00%0.33%0.66%0.99%0.3%0.5%0.5%0.5%0.5%Aug 26Oct 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

3 pkgs affected
🐘cakephp/authentication🐘cakephp/authentication🐘cakephp/authentication

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

CakePHP Authentication is an authentication plugin for CakePHP that can also be used in PSR-7 based applications. Prior to 2.11.1, 3.3.6, and 4.1.1, the getLoginRedirect() method contains a weakness to backslash bypasses that allows redirect targets with attacker-controlled hostnames through the redirect query string parameter. This issue is fixed in versions 2.11.1, 3.3.6, and 4.1.1.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistcakephp/authentication≥ 3.0.0&&< 3.3.63.3.6composer require cakephp/authentication:^3.3.6
🐘Packagistcakephp/authentication≥ 4.0.0&&< 4.1.14.1.1composer require cakephp/authentication:^4.1.1
🐘Packagistcakephp/authenticationall versions2.11.1composer require cakephp/authentication:^2.11.1

Affected Products

1 product · 3 configurations
Application
cakephpcakephp
≥ 4.0.0 && < 4.1.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for cakephp/authentication, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update cakephp/authentication to 3.3.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-hhpq-7wg4-36jm is resolved across your whole dependency graph.

  3. Workarounds

    Stop reflecting attacker-controlled destinations: resolve every redirect target against an allowlist of paths or hosts you own, prefer a server-side key over a full URL in the request, and reject absolute URLs entirely where the flow only ever needs a relative one.

Frequently Asked Questions

### Impact The `getLoginRedirect()` method contains a weakness to backslash bypasses allowing redirect targets with attacker controlled hostnames. ### Patches 2.11.1, 3.3.6 and 4.1.1 contain a fix for this issue. ### Workarounds If you are unable to upgrade, you should consider adding application validation to the redirect query string parameter to mitigate this vulnerability.
O3 Security · Impact-Aware SCA

Is GHSA-hhpq-7wg4-36jm in your dependencies?

Find it across Packagist, including transitive dependencies.

CakePHP Authentication: Open redirect weakness via…