TYPO3 CMS Possible Insecure Deserialization in Extbase Request HandlingGHSA-hh95-5xm5-v8v7
HIGHFix: TYPO3/typo3@57e4ed3GHSA-hh95-5xm5-v8v7 is a high-severity (CVSS 8.1) remote code execution vulnerability in typo3/cms. A fix is available for typo3/cms — see the affected versions and patch details below.
Real-World Exposure
typo3/cms🐘typo3/cmsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
It has been discovered that request handling in Extbase can be vulnerable to insecure deserialization. User submitted payload has to be signed with a corresponding HMAC-SHA1 using the sensitive TYPO3 encryptionKey as secret - invalid or unsigned payload is not deserialized.
However, since sensitive information could have been leaked by accident (e.g. in repositories or in commonly known and unprotected backup files), there is the possibility that attackers know the private encryptionKey and are able to calculate the required HMAC-SHA1 to allow a malicious payload to be deserialized.
Requirements for successfully exploiting this vulnerability (all of the following):
- rendering at least one Extbase plugin in the frontend
- encryptionKey has been leaked (from LocalConfiguration.php or corresponding .env file)
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | typo3/cms | ≥ 8.0.0&&< 8.7.30 | 8.7.30composer require typo3/cms:^8.7.30 |
| 🐘Packagist | typo3/cms | ≥ 9.0.0&&< 9.5.12 | 9.5.12composer require typo3/cms:^9.5.12 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update typo3/cms to 8.7.30 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-hh95-5xm5-v8v7 is resolved across your whole dependency graph.
Workarounds
Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.
Frequently Asked Questions
Is GHSA-hh95-5xm5-v8v7 in your dependencies?
Find it across Packagist, including transitive dependencies.