Volcano Scheduler Denial of Service via Unbounded Response from Elastic Service/extender PluginGHSA-hg79-fw4p-25p8
Fix: volcano-sh/volcano@45a4347GHSA-hg79-fw4p-25p8 is a CWE-770 vulnerability in volcano.sh/volcano. A fix is available for volcano.sh/volcano — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-hg79-fw4p-25p8.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
volcano.sh/volcano🐹volcano.sh/volcano🐹volcano.sh/volcano🐹volcano.sh/volcano🐹volcano.sh/volcanoReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Volcano is a Kubernetes-native batch scheduling system. Prior to versions 1.11.2, 1.10.2, 1.9.1, 1.11.0-network-topology-preview.3, and 1.12.0-alpha.2, attacker compromise of either the Elastic service or the extender plugin can cause denial of service of the scheduler. This is a privilege escalation, because Volcano users may run their Elastic service and extender plugins in separate pods or nodes from the scheduler. In the Kubernetes security model, node isolation is a security boundary, and as such an attacker is able to cross that boundary in Volcano's case if they have compromised either the vulnerable services or the pod/node in which they are deployed. The scheduler will become unavailable to other users and workloads in the cluster. The scheduler will either crash with an unrecoverable OOM panic or freeze while consuming excessive amounts of memory. This issue has been patched in versions 1.11.2, 1.10.2, 1.9.1, 1.11.0-network-topology-preview.3, and 1.12.0-alpha.2.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | volcano.sh/volcano | all versions | 1.9.1go get volcano.sh/volcano@v1.9.1 |
| 🐹Go | volcano.sh/volcano | ≥ 1.10.0-alpha.0&&< 1.10.2 | 1.10.2go get volcano.sh/volcano@v1.10.2 |
| 🐹Go | volcano.sh/volcano | ≥ 1.11.0-network-topology-preview.0&&< 1.11.0-network-topology-preview.3 | 1.11.0-network-topology-preview.3go get volcano.sh/volcano@v1.11.0-network-topology-preview.3 |
| 🐹Go | volcano.sh/volcano | ≥ 1.11.0&&< 1.11.2 | 1.11.2go get volcano.sh/volcano@v1.11.2 |
| 🐹Go | volcano.sh/volcano | ≥ 1.12.0-alpha.0&&< 1.12.0-alpha.2 | 1.12.0-alpha.2go get volcano.sh/volcano@v1.12.0-alpha.2 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for volcano.sh/volcano, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update volcano.sh/volcano to 1.9.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-hg79-fw4p-25p8 is resolved across your whole dependency graph.
Workarounds
Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.
Frequently Asked Questions
Is GHSA-hg79-fw4p-25p8 in your dependencies?
Find it across Go, including transitive dependencies.