NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
.NET
.NET NuGet
Not in CISA KEV
HIGH severity

ImageMagick: Integer overflow in DIB coder can result in out of bounds read or writeGHSA-hffp-q43q-qq76

HIGH

GHSA-hffp-q43q-qq76 is a high-severity (CVSS 8.1) Out-of-bounds Read vulnerability in Magick.NET-Q16-AnyCPU. A fix is available for Magick.NET-Q16-AnyCPU — see the affected versions and patch details below.

Also known asCVE-2026-28693
Published
Updated
Affected
19 pkgs
Patched
19 / 19
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-hffp-q43q-qq76.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk+0.04%
Lower risk than most CVEs33th percentile — riskier than 33% of all scored CVEsHighest risk
0.00%0.36%0.71%1.07%0.1%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

19 pkgs affected
.NETMagick.NET-Q16-AnyCPU.NETMagick.NET-Q16-HDRI-AnyCPU.NETMagick.NET-Q16-HDRI-OpenMP-arm64.NETMagick.NET-Q16-HDRI-arm64.NETMagick.NET-Q16-HDRI-x64.NETMagick.NET-Q16-HDRI-x86.NETMagick.NET-Q16-OpenMP-arm64.NETMagick.NET-Q16-OpenMP-x64+11 more

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects NuGet packages — download data is not available via public APIs for these ecosystems.

Description

ImageMagick is free and open-source software used for editing and manipulating digital images. Prior to versions 7.1.2-16 and 6.9.13-41, an integer overflow in DIB coder can result in out of bounds read or write. This vulnerability is fixed in 7.1.2-16 and 6.9.13-41.

Affected Packages

19 total 19 fixed
EcosystemPackageVulnerable rangeFix
.NETNuGetMagick.NET-Q16-AnyCPUall versions14.10.4dotnet add package Magick.NET-Q16-AnyCPU --version 14.10.4
.NETNuGetMagick.NET-Q16-HDRI-AnyCPUall versions14.10.4dotnet add package Magick.NET-Q16-HDRI-AnyCPU --version 14.10.4
.NETNuGetMagick.NET-Q16-HDRI-OpenMP-arm64all versions14.10.4dotnet add package Magick.NET-Q16-HDRI-OpenMP-arm64 --version 14.10.4
.NETNuGetMagick.NET-Q16-HDRI-arm64all versions14.10.4dotnet add package Magick.NET-Q16-HDRI-arm64 --version 14.10.4
.NETNuGetMagick.NET-Q16-HDRI-x64all versions14.10.4dotnet add package Magick.NET-Q16-HDRI-x64 --version 14.10.4
.NETNuGetMagick.NET-Q16-HDRI-x86all versions14.10.4dotnet add package Magick.NET-Q16-HDRI-x86 --version 14.10.4

Affected Products

1 product · 2 configurations
Application
imagemagickimagemagick
≥ 7.0.0-0 && < 7.1.2-16
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for Magick.NET-Q16-AnyCPU, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update Magick.NET-Q16-AnyCPU to 14.10.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-hffp-q43q-qq76 is resolved across your whole dependency graph.

  3. Workarounds

    Constrain what reaches the vulnerable code: limit the size and shape of untrusted input, isolate the affected component in a sandboxed or least-privileged process, and enable the platform's memory-safety mitigations (ASLR, stack protector, hardened allocator) so an out-of-bounds access is more likely to fail closed than to be exploitable.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant

This is an IMPORTANT vulnerability in ImageMagick where an integer overflow in the DIB image coder can lead to out-of-bounds read or write operations. This flaw could result in arbitrary code execution or denial of service when processing a specially crafted DIB image. Red Hat Enterprise Linux 6 ELS and 7 ELS are…

Workaround published by Red Hat
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base, or stability.
Source: Red Hat security advisory for GHSA-hffp-q43q-qq76 (CC BY 4.0)
ProductFixed inAdvisory
Red Hat Enterprise Linux 7 Extended Lifecycle SupportImageMagick-0:6.9.10.68-15.el7_9RHSA-2026:6713

Frequently Asked Questions

An integer overflow in DIB coder can result in out of bounds read or write
O3 Security · Impact-Aware SCA

Is GHSA-hffp-q43q-qq76 in your dependencies?

Find it across NuGet, including transitive dependencies.

ImageMagick: Integer overflow in DIB coder can result in…