NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

Cross-site Scripting in @rocket.chat/livechatGHSA-hf55-c445-2w97

MEDIUMFix: RocketChat/Rocket.Chat.Livechat#558

GHSA-hf55-c445-2w97 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in @rocket.chat/livechat. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for @rocket.chat/livechat — see the affected versions and patch details below.

Also known asCVE-2022-21830
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs56th percentile — riskier than 56% of all scored CVEsHighest risk
0.00%0.42%0.85%1.27%0.4%0.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

0other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
@rocket.chat/livechatnpm
364downloads / week

Description

A blind self XSS vulnerability exists in RocketChat LiveChat versions lower than 1.9 that could allow an attacker to trick a victim pasting malicious code in their chat instance.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npm@rocket.chat/livechatall versions1.9.0npm install @rocket.chat/livechat@1.9.0

Affected Products

1 product · 1 configurations
Application
livechatrocket.chat
< 1.9.0
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @rocket.chat/livechat, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update @rocket.chat/livechat to 1.9.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-hf55-c445-2w97 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

A blind self XSS vulnerability exists in RocketChat LiveChat versions lower than 1.9 that could allow an attacker to trick a victim pasting malicious code in their chat instance.
O3 Security · Impact-Aware SCA

Is GHSA-hf55-c445-2w97 in your dependencies?

Find it across npm, including transitive dependencies.

Cross-site Scripting in @rocket.chat/livechat (Medium 6.1)